Friday, October 24, 2014

[Solved] Joomla! 2.5 Installation stuck Step 4

Shared from a Joomla Forum
http://forum.joomla.org/viewtopic.php?f=707&t=793044&start=30

I faced the same problem, i tried this
open the file : \installation\inedx.php

Added the bolded lines in the file and saved it and tried, its worked
in version = > 2.5

/*
* Joomla system checks.
*/
error_reporting(E_ALL);
@ini_set('magic_quotes_runtime', 0);
@ini_set('zend.ze1_compatibility_mode', '0');

/*
* increase the timeout for the PHP , to prevent struck in DataBase creation.
*/

if (ini_get('max_execution_time')=='30') {
@ini_set('max_execution_time', '3000');
}


in version => 3.3

if (version_compare(PHP_VERSION, '5.3.10', '<'))
{
die('Your host needs to use PHP 5.3.10 or higher to run this version of Joomla!');
}

/*
* increase the timeout for the PHP , to prevent struck in DataBase creation.
*/

if (ini_get('max_execution_time')=='30') {
@ini_set('max_execution_time', '3000');
}


This will change the setting only for the current scripting , so it won't affect any other scripts :P